Content Scripts UI Requires All Imports to be Present in a Production Build

Resolved
Partial outage
Started almost 2 years ago Lasted about 15 hours

Affected

Framework
Updates
  • Resolved
    Resolved

    0.42.6 fixes this

  • Identified
    Identified

    We've just pushed a fix to this issue, and will deploy it soon: https://github.com/PlasmoHQ/plasmo/commit/a9b72d145f04cb6edf3f79c2fde14913ee0005bc

  • Investigating
    Investigating

    TL;DR: Parcel does tree shaking on production bundles which is messing with our parsing of exports. We're investigating the right way to solve this.

    Relevant Github issue: https://github.com/PlasmoHQ/plasmo/issues/20